본문 바로가기

LGPL 3.0 관련 문의

mjbae 게시글 작성 시각 2023-11-06 11:19:20 게시글 조회수 428

 

 

안녕하세요. 

Flutter로 앱을 빌드하여 플레이스토어 및 앱스토어에 게시할 계획입니다.

 

간단한 동영상 편집을 위해 video_trimmer 플러그인을 사용하고자하는데 여기에는 MIT 라이센스로 고지되어있으나,

https://pub.dev/packages/video_trimmer

 

이 프로젝트가 의존하는 ffmpeg_kit_flutter 플러그인의 경우 LGPL 3.0 라이센스로 고지되어있습니다.

https://pub.dev/packages/ffmpeg_kit_flutter

 

1) 제가 알기로 LGPL 3.0 의존성이 있는 라이브러리를 사용할 경우 자신의 소스도 LGPL 3.0이 되는 것으로 알고 있는데, video_trimmer 플러그인이 라이센스를 잘못 고시하고 있는걸까요? 아니면 소스 수정없이 라이브러리 링크이기 때문에 LGPL 3.0 의존성이 있더라도 MIT 라이센스로 배포하는 것이 가능한걸까요? 그렇다면 제가 video_trimmer을 쓸 경우 MIT 라이센스만 준수하면 되는지 궁금합니다.

 

2) 소스 수정없는 라이브러리 링크가 괜찮다면 제가 직접 ffmpeg_kit_flutter을 플러그인을 사용하여 개발 후에 앱스토어에 배포하더라도 저희 앱의 소스코드 공개의무는 발생하지 않을 수 있을까요? 

 

3) ffmpeg_kit_flutter와 같은 LGPL-3.0 라이브러리를 직접 사용한 앱을 개발하는 경우, 가이드 문서 83페이지의 LGPL-3.0 > (2) 바이너리 배포 > 2) 라이브러리 링킹 결합의 공통의무사항/공통 금지사항에 해당하는 것 같은데 맞을까요?

그런데 앱의 경우 라이브러리는 아니라고 여겨져서, "라이브러리를 사용하는 저작물" , "디버깅 허용",  "라이브러리임을 명시" 등의 조항을 어떻게 적용해야할지 모르겠습니다.

https://www.oss.kr/oss_guide/show/a17c94f3-a470-4e1d-8cfe-d5d15d6535f7

20231106111850e29dff6e5102e81716e5129422551737874a9701.png

 

감사합니다.

 

 

맨 위로
맨 위로