예를들어, A라는 오픈소스 라이브러리가 Apache 2.0 License로 작성되어 있습니다만.

3rd-party 라이브러리들이 BSD라던가 다른 레벨의 Apache라이센스를 사용하고 있고,

LICENSE

LICENSE.3rd_party_library

LICENSE.3rd_party_model

상기와 같이 명시되어 있는 상황입니다.

 

해당 패키지를 사용하여 SW를 개발 후, 상용 배포를 위해서는

 

명시된 3rd-party 라이브러리들의 라이센스까지 전부 검토하여 제공되어야 하나요?

혹은 이미 3rd-party 라이브러리들을 이용해 개발해놓은 최종 License가 Apache 2.0을 따르므로, 해당 라이센스만 만족하면 될까요?

 

이상입니다. 감사합니다.

맨 위로
맨 위로