Home > 열린마당 > 공개SW 소식

공개SW 소식

리눅스서 치명적 보안 취약점 발견 … 'GnuTLS 라이브러리’ 긴급 패치 공개

OSS 게시글 작성 시각 2014-03-06 14:49:42 게시글 조회수 1577

2014년 03월 06일 (목)

ⓒ ITWorld, Jon Gold, | Network World



다양한 리눅스 배포판에서 보안 인터넷 접속을 관리하기 위해 사용되는 오픈소스 빌딩 블록인 'GnuTLS 라이브러리’에서 치명적인 보안 취약점이 발견됐다. 소스코드 작성 과정의 실수가 원인으로 리눅스 사용자의 다양한 정보가 유출되는 심각한 위협이 될 수 있어, 급히 패치를 내놨다.

GnuTLS의 개발자인 니코스 마브로지아나폴러스는 3일 메일링 리스트 메시지를 통해 이러한 보안 취약점을 수정한 패치를 공개했다. 이 보안 취약점을 이용하면 해커가 GnuTLS 시스템 인증을 우회해 보안 연결을 통한 인터넷 통신 데이터를 엿볼 수 있다.

해커는 특정 형태의 가짜 인증을 만드는 방식으로 GnuTLS에 정상적으로 접속해 새로운 보안 연결을 생성하는데, 이렇게 되면 인터넷 연결을 통해 주고 받는 메시지 내용을 평문 형태로 고스란히 빼갈 수 있다. 다른 해킹에 사용하기 위한 보안 연결을 생성하는 악성코드를 심을 수도 있다.

마브로지아나폴러스는 "이 버그는 (내가 소속된) 레드햇을 대표해 코드를 확인하는 과정에서 발견됐다"며 '부끄러운 버그’라고 밝혔다. 현재 우분투와 데비안, 페도라, 레드햇, 오라클, 슬랙웨어, 수세 등 유명 리눅스 배포판들은 그가 공개한 패치를 적용한 상태다.

이번 리눅스 보안 취약점 발견 소식은 애플의 iOS와 OS X에서 비슷한 문제가 발견돼 패치한 지 며칠 뒤에 나왔다. 애플의 사례가 널리 알려지면서 다른 부문에서도 비슷한 취약점이 있는지 환기하는 효과가 있었다는 분석이 나오고 있다.



※ 본 내용은 한국IDG(주)(http://www.itworld.co.kr)의 저작권 동의에 의해 공유되고 있습니다.
Copyright ⓒITWORLD. 무단전재 및 재배포 금지


[원문출처 : http://www.itworld.co.kr/news/86369]

맨 위로
맨 위로