Home > 열린마당 > 공개SW 소식

공개SW 소식

2018년 11월 09일

ⓒ 보안뉴스

 

엔진엑스(nginx)라는 오픈소스 웹 서버 소프트웨어의 업데이트가 발표됐다. 여러 개의 디도스 유발 취약점들이 발견된 데에 따른 조치이다.

 

엔진엑스는 웹 서버 기능을 하는 소프트웨어이지만 서버 부하 분산 장치(load balancer)나 리버스 프로시(reverse proxy)로 사용되기도 한다. 실제로 현재 약 4억 개가 넘는 웹사이트들에서 엔진엑스가 활용되고 있다. 세계에서 가장 널리 쓰이는 웹 서버 중 하나다.

엔진엑스를 개발한 건 엔진엑스 인코퍼레이션(NGINX, Inc.)이다. 현재까지 1억 달러의 투자까지 유치해 낸 촉망받는 기업으로, 그중 4천 3백만 달러는 올해 6월에 받기도 했다.

엔진엑스 개발자들은 이번 주 1.15.6 버전과 1.14.1을 발표하며, 두 개의 HTTP/2 관련 취약점들을 해결했음을 공지했다. 이 두 가지 취약점을 익스플로잇 할 경우 디도스 공격이 가능해진다. 취약점이 발견된 버전은 1.9.5~1.15.5이다.

이 중 하나의 취약점은 CVE-2018-16843으로 과도한 메모리 소모 현상을 발생시킬 수 있다. 또 다른 취약점은 보안 업체 F5 네트웍스(F5 Networks)의 갈 골드슈타인(Gal Goldshtein)이란 인물이 발견한 것으로, CVE-2018-16844다. 과도한 CPU 소모 현상을 발생시킨다.

엔진엑스의 코어 개발자인 막심 두닌(Maxim Dounin)은 환경설정 파일 내에서 listen 명령의 http2 옵션이 사용되는 경우 엔진엑스가 디폴트가 아니라 ngx_http_v2_module로 컴파일 될 경우 문제가 생긴다고 설명한다.

여기에 더해 엔진엑스를 사용하는 웹사이트의 관리자들에게는 ngx_http_mp4_module이라는 모듈에서도 보안 문제가 있을 수 있다는 내용이 전달됐다. 이 모듈은 MP4 미디어 파일들을 지원하는 수도 스트리밍(pseudo-streaming) 기능을 제공한다.

(생략)
       
 [원문기사 보기 : https://www.boannews.com/media/view.asp?idx=74492&kind=1]

맨 위로
맨 위로