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1. 문서 개요

Ajax (Asynchronous JavaScript + XML)는 브라우저에서 실행되는 웹 애플리케이션을 데스크

탑용 소프트웨어 수준으로 끌어 올리는 방식으로 빠르게 대두되고 있다. 

Linux-Apache-MySQL-PHP (LAMP) 같은 오픈 소스 소프트웨어와 IBM® WebSphere® 

Application Server Community Edition 같은 오픈 표준 기반 Java™ 2 Platform, Enterprise 

Edition 미들웨어는 Ajax 웹 애플리케이션들을 개발 및 전개하는 탁월한 기능들을 제공하고 있

다. 본 문서에서는 오픈 소스 미들웨어 스택을 사용하여 엔드투엔드 Ajax 애플리케이션을 개발

환경구축 방법에 관한 내용을 다루고자한다. 

가. 문서의 목적

다음과 같은 세부적인 목적을 달성하기 위하여 작성되었다.

○ AJAX 개발환경 소개 및 기능 분석
○ 관련 아키텍쳐 구조 설명

나. 본 문서의 사용방법

다음과 같은 방법으로 사용할 수 있다.

      ○ 국내 웹개발자에게 새롭게 추가된 기술을 소개할 수 있다.
      ○ 사용자들에게 새로운 기능들에 대한 내용을 홍보할 수 있다. 

다. 참고사항

      ○ 개발지원시 시스템 관련사항, 기술적 배경 등 참고사항들을 기술한다.
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항목 지원 내용 비고

AJAX 환경설정 소개 
l 한국소프트웨어진흥원 공개SW기술지원센터 자체 

신기술 조사요청에 의해 AJAX Application 기술 

검토

 

구 분 비 고

기관명 -

담당자 -

연락처 -

회사 위치 -

2. 신기술/기능 요구사항

가. 대상 업체

 

나. 요구 사항
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3. AJAX 개요

Ajax (Asynchronous JavaScript + XML)는 브라우저에서 실행되는 웹 애플리케이션을 데

스크탑용 소프트웨어 수준으로 끌어 올리는 방식으로 빠르게 대두되고 있다. 

Linux-Apache-MySQL-PHP (LAMP) 같은 오픈 소스 소프트웨어와 IBM® WebSphere® 

Application Server Community Edition 같은 오픈 표준 기반 Java™ 2 Platform, 

Enterprise Edition 미들웨어는 Ajax 웹 애플리케이션들을 개발 및 전개하는 탁월한 기능들

을 제공하고 있다. 본 문서에서는 오픈 소스 미들웨어 스택을 사용하여 엔드투엔드 Ajax 애

플리케이션의 개발환경을 다루고자 한다. 

Ajax는 오늘날 아키텍트, 개발자, 제품 매니저 및 웹 기반 애플리케이션의 고객들 사이에서 

많은 관심을 받고 있는 Web 2.0 기술의 일부이다. Ajax 프로그래밍 기술은 XHTML, 

JavaScript, CSS, XML Http Request (XHR) 같은 입증된 기술들로 구성되어 있다. 

Representational State Transfer (REST)와 JavaScript Object Notation (JSON) 같은 대

중적인 서비스 액세스와 데이터 교환 기술들은 Ajax 기술에 잘 맞는다. 클라이언트 티어에서 

이와 같이 입증된 강점들은 PHP, Python, Ruby 같은 오픈 소스 기술들로 결합되어 Ajax 

스토리를 멀티 티어 애플리케이션 개발로 확장할 수 있다. 여기에 데이터 티어에는 MySQL

이라고 하는 오픈 소스 데이터베이스의 성공이 추가되었다. 

Ajax 프로그래밍 기술과 잘 맞는 다른 것으로는 오픈 소스이며 무료로 다운로드 및 사용할 

수 있는 Eclipse 기반 개발 툴들이다. 이들이 함께 결합하여 클라이언트 티어, 미들 티어, 데

이터 티어 기술들은 웹 애플리케이션 개발을 시도 및 배울 수 있는 토대를 제공한다.

전형적인 엔터프라이즈 급의 웹 애플리케이션은 매우 강력한 요소들을 다루고 있다. 선별된 

오픈 소스 오퍼링의 핵심 구현 블록에 대해 배운다고 해서, 본 시나리오에서 보안, 확장성, 

가용성 같은 엔터프라이즈 수준의 중요한 특징들은 다루지 않을 것이다. 본 문서에서 다루는 

내용들은 본 시나리오에서 기술된 Ajax 애플리케이션의 특정 클래스에만 적용된다. 특히, 본 

문서에서는 MySQL 데이터베이스 생성, PHP 런타임 환경에서 미들 티어/데이터베이스 로직 

디자인 및 개발, JavaScript를 사용하여 진정한 싱글 페이지 Ajax 클라이언트 인터페이스 생

성하는 방법을 설명한다. Eclipse에서 Ajax 애플리케이션을 개발 및 테스트 하고, Firefox 

(클라이언트 티어), Zend PHP (미들 티어), MySQL (데이터 티어)에 이를 전개하는 단계를 

코드 샘플을 통해 설명한다. XHTML, CSS, JavaScript, XHR, DOM, REST, SOAP, JSON, 

XML, PHP, MySQL, Eclipse를 여러분의 애플리케이션에 통합하는 방법을 통해 오픈 소스 

플랫폼에 구현된 많은 기능들을 알 수 있을 것이다. 본 시리즈에서는 애플리케이션 티어들을 

완벽히 분리하여 깔끔하고 고급스러운 웹 애플리케이션 디자인을 만드는 방법을 설명한다. 

클라이언트 티어에는 XHTML, CSS, JavaScript, XML Http Request (XHR)가 포함되어 있

다. 이미 언급된 미들 티어 오픈 소스 기술들 중에서, 본 문서에서는 PHP를 사용한다. 

MySQL 데이터베이스는 데이터 티어에 사용된다. 게다가, 본 시리즈는 REST, SOAP, JSON, 

XML 같은 웹 서비스 기술들도 사용한다. 

다음의 단계들을 따라, 엔드투엔드 애플리케이션 개발에 필요한 런타임 및 개발 환경을 설치 

및 설정한다. 유용한 Hello World 애플리케이션 대신, 뱅킹 시나리오를 분석 및 파악할 것이
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다. 이 시나리오에서는 가상의 은행, 이것의 백엔드 데이터베이스, 브라우저 기반 은행 고객 

포털, 실제 서드 파티 금융 관련 웹 서비스의 정황 속에서 앞서 언급한 기술 컴포넌트들을 

사용하는 방법을 설명할 예정이다.

4. 필요한 소프트웨어 패키지

모든 애플리케이션 티어들로 확장되는 은행 시나리오를 개발 및 전개하려면 그러한 티어들에

서 다음을 선택해야 한다. 

l 웹 브라우저 

l 데이터베이스 서버 

l 웹 서버 

l 미들 티어 서버 

l 미들 티어 코드 개발용 IDE 

l 클라이언트 티어 코드 개발용 IDE 

모든 레이어에서 사용할 수 있는 많은 오픈 소스 오퍼링 중에서, 본 시리즈에서는 다음을 사

용한다.

l 웹 브라우저: Mozilla Firefox 2.0.0.4 또는 이후 버전. Firefox의 장점은 가용성, 온라인 

보안, 수백 개의 애드온 애플리케이션들을 통한 커스터마이징을 들 수 있다. Firefox의 

브라우저 애플리케이션 디버거 애드온인 Firebug도 사용할 수 있다.

l 데이터베이스 서버: MySQL 5.0.41 또는 이후 버전. 클라이언트/서버 모드와 임베디드 모

드에서 작동한다. C와 C++로 작성되었다. Enterprise 서버와 Community 서버 에디션

에서 사용할 수 있다. 

l 웹 서버: Apache Web server 2.2.2. 서드 파티 모듈로 설정 및 확장 가능하다.

l 미들 티어 서버: Zend Core 2.0.1 또는 이후 버전. 이 무료의 오픈 소스 서버는 PHP 5

를 지원한다. 강력한 커뮤니티 지원을 받고 있다. Apache 웹 서버가 포함되어 있으며, 

MySQL, IBM DB2®, Oracle 같은 데이터베이스를 지원한다. Zend Core for IBM은 

IBM DB2에 작동하도록 특별히 조정되었다. 그림 1은 Zend Core의 개요도이다.

l 미들 티어 IDE (Integrated Development Environment): Eclipse PDT 0.7 RC3 또는 

이후 버전. PDT는 Eclipse 플랫폼용 PHP Development Tool로서 PHP 애플리케이션 

개발에 필요한 모든 개발 컴포넌트를 포함하고 있다. PHP 디버깅은 이 IDE에서도 지원

된다. Zend, IBM, 기타 기업들은 이를 오픈 소스에 기여하고 있다. 

클라이언트 티어 IDE: Aptana Web IDE 0.2.8.14433 또는 이후 버전. Ajax 브라우저 애플

리케이션들을 개발하는 무료의, 오픈 소스, 크로스 플랫폼, JavaScript 중심의 개발 환경이

다. JavaScript, HTML, CSS용 코드 지원을 제공한다. JavaScript 디버깅을 지원하고 여러 

Ajax 프레임웍들을 위한 빌트인 지원이 포함된다. 무엇보다도, Eclipse 기반이다. 
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그림 1. Zend Core 개요 

가. Firefox 설치

다음 단계는 Mozilla Firefox의 설치 단계이다. 

1. c:\temp\dw-ajax라고 하는 임시 디렉토리를 만들어서, 여기에 다양한 소프트웨어 패키

지들을 위한 설치 파일들을 저장한다. 

2. 아래 참고자료 섹션을 참조하여 Mozilla URL에서 Mozilla Firefox 2.0.0.4 또는 이후 버

전을 다운로드 하여 이것을 c:\temp\dw-ajax에 저장한다. 

3. 다운로드 한 파일을 실행하여 Mozilla Firefox 2.0.0.4를 설치한다. 

l Mozilla 설치 마법사에서 Next를 클릭한다. 

l 라이센스 동의를 수락하고 Next를 클릭한다. 

l Custom을 선택하고 Next를 클릭한다. 

l DOM Inspector와 Quality Feedback Agent 옵션들이 모두 선택되었는지 확인하고 Next

를 클릭한다. 

l 기본 설치 폴더를 수락하고 Next를 클릭한다. 

l 처음 두 개의 옵션들(On my Desktop과 In my Start Menu Programs Folder)이 선택되

지 않도록 한다. 

l 설치가 완료되면, Launch Mozilla Firefox now 옵션이 선택되었는지를 확인한다. 

l Finish를 클릭한다. 

l Mozilla Firefox를 기본 브라우저로 하라는 프롬프트에서 Yes를 선택한다. 

l Firefox 브라우저를 시작하고 참고자료 섹션에 나온 Mozilla Firefox URL로 간다. 

l 페이지 위쪽에 있는 Add-ons를 클릭한다. 

l Firefox 웹 사이트의 검색 바에서 Firebug를 입력하고 Search를 클릭한다. 

l 검색 결과에서 Firebug를 클릭한다. 

l Install now를 클릭한다. 팝업 박스에서, Install now를 클릭한다. 

l Restart Firefox를 클릭한다. 

l Firefox에서, Tools->Firebug->Open Firebug를 클릭한다. 

l 브라우저 윈도우 밑에 Firebug 실행 불가를 나타내는 메시지를 보면 Enable Firebug를 
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클릭한다. 

l Firefox 브라우저를 닫는다. 

나. MySQL 설치

다음 단계는 MySQL의 설치 단계이다. 

1. MySQL URL로 이동. 

2. MySQL Community Server를 클릭한다. (클릭하면 권장 GA 버전으로 바로 간다.) 

3. 5.0.41 또는 이후 버전용 Windows (x86) Zip/Setup.EXE를 다운로드 하고 이를 

c:\temp\dw-ajax 디렉토리에 저장한다. (.zip 파일에는 단 한 개의 파일만 포함되어 있

는데, 이는 MySQL용 설치 파일이다.) 

4. .zip 파일에서 MySQL 설치 파일을 추출하고 이를 c:\temp\dw-ajax 디렉토리에 저장

한다. 

5. 4단계에서 추출한 실행 파일(Setup.exe)을 실행한다. 

l Next를 클릭한다. 

l 설정 유형을 Complete으로 선택하고 Next를 클릭한다. 

l Install을 클릭한다. 

l Skip Sign-Up을 선택하고 Next를 클릭한다. 

l Configure the MySQL Server now가 선택되었는지를 확인하고 Finish를 클릭한다. 

MySQL Server Instance Configuration Wizard가 열린다. 

l Next를 클릭한다. 

l Detailed Configuration을 선택하고 Next를 클릭한다. 

l Developer Machine을 선택하고 Next를 클릭한다. 

l Select Multifunctional Database를 선택하고 Next를 클릭한다. 

l InnoDB Tablespace Settings에서, 기본 옵션을 수락하고 Next를 클릭한다. 

l Decision Support (DSS)/OLAP를 선택하고 Next를 클릭한다. 

l Enable TCP/IP Networking과 Enable Strict Mode 옵션이 선택되었는지를 확인하고 

Next를 클릭한다. 

l Standard Character Set를 선택하고 Next를 클릭한다. 

l Install As Windows Service와 Include Bin Directory in Windows PATH 옵션이 선택

되었는지를 확인하고 Next를 클릭한다. 

l 새로운 루트 패스워드로 webtech를 입력하고 Next를 클릭한다. 

l Execute를 클릭한다. 

l Finish를 클릭한다. 

다. Apache 와 Zend Core PHP 설치 

Zend Technologies Ltd.는 Zend Core를 무료로 제공한다. 여기에는 Apache 웹 서버가 포

함되어 있다. 다음 단계를 따라서 Apache 웹 서버와 Zend Core PHP 서버를 설치한다.

Zend Core를 무료로 다운로드 하려면, Zend 웹 사이트에 등록해야 한다. 
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1. Zend 웹 사이트에 등록되면, 참고자료 섹션에 나온 Zend Core URL로 가서 로그인 하여 

다운로드 부분으로 간다. 

2. Agree to EULA 체크 박스를 선택하고 Submit을 클릭한다. 

3. Zend Core Generic 섹션에서, Zend Core Windows x86 (Version v2.0.1 또는 이후 버

전)을 다운로드 하고 c:\temp\dw-ajax 디렉토리에 .zip 파일을 저장한다. (.zip 파일에

는 Zend Core용 설치 파일만 있다.) 

4. .zip 파일에서 Zend Core 설치 파일을 추출하고 이를 c:\temp\dw-ajax 디렉토리에 저

장한다. 

5. ZendCore-v2.0.1-Windows-x86.exe 또는 이후 버전을 실행한다. 

l Next를 클릭한다. 

l 라이센스 동의를 수락하고 Next를 클릭한다. 

l 설정 유형으로 Complete를 선택하고 Next를 클릭한다. 

l Skip Sign-Up을 선택하고 Next를 클릭한다. 

l 기본 위치를 수락하고 Next를 클릭한다. 

l Install bundled Apache 2.2.2를 선택하고 Next를 클릭한다. 

l 기본 포트80을 선택하고 Next를 클릭한다. 

l 기본 확장 제휴를 수락하고 Next를 클릭한다. 

l 관리 콘솔 패스워드를 webtech로 입력하고 Next를 클릭한다. 

l Zend Network Registration이 No로 설정되었는지를 확인하고 Next를 클릭한다. 

l Install을 클릭하여 설치를 시작하고 Zend Core가 완전히 설치될 때까지 기다린다. Zend 

Core 파일을 복사한 후에, 인스톨러는 Microsoft Visual C++ 의 재배포 가능 버전을 

설치한다. 이후에 Zend Core 설치 프로그램은 Zend Core Administration URL의 메시

지 다이얼로그를 디스플레이 함으로써 Zend Core 설치 프로그램을 종료한다. 

l OK를 클릭하고 메시지 다이얼로그를 닫는다. 

l Finish를 클릭하여 설치 완료 다이얼로그를 닫는다. 

l c:\Program Files\Zend\Apache2\bin 디렉토리로 가서 ApacheMonitor 프로그램을 

더블 클릭한다. Apache Monitor가 트레이 아이콘 모양으로 태스크 바에 나타난다. 이 트

레이 아이콘을 사용하여 Apache와 Zend 서버를 시작 및 중지한다. 

6. Zend Core를 설정하기: 

l Windows Start Menu에서, Programs->Zend Core->Zend Core Administration 

Console을 선택한다. 

l 패스워드 webtech를 입력한다. 

l Configuration 탭(그림 2)을 클릭한다. 

l Extensions 탭을 클릭한다. 

l curl - URL을 리스트에 배치하고 Enable/Disable 바의 빨간색 원 위를 클릭하여 빨간색 

원이 녹색이 되게 한다. 

l 리스트에 mysqli - MySQL improved를 배치하고, enable/disable 바 위의 빨간색 원 위

를 클릭하여 녹색이 되게 한다. 

l 페이지의 우측 상단 코너에 Save Settings를 클릭한다. 
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그림 2. Zend Core 설정화면

l Logout을 클릭한다. 

7. 태스크 바의 Apache 트레이 아이콘을 클릭하고 Apache2 HTTP Server->Restart를 선

택한다.

라. Eclipse의 PHP Development Tool(PDT) 설치

현재, PDT가 유일한 릴리스 후보이고, 아직은 Eclipse 플랫폼을 위해 완벽히 릴리스 된 플

러그인은 아니다. 다음 단계들을 통해 Eclipse PDT를 설치 및 설정한다. (PDT는 Eclipse와 

Zend 웹 사이트에서 사용할 수 있다. Zend 웹 사이트는 Zend용 PHP 디버깅 툴이 추가되었

고 Eclipse 웹 사이트와 같은 버전을 제공한다.)

1. zend.com의 Eclipse PDT 다운로드 페이지로 간다.

l Version 0.7 RC3 또는 이후 버전을 다운로드 하고 c:\temp\dw-ajax 디렉토리에 .zip 
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파일을 저장한다.

l pdt-0.7.0.S20070401-RC3외 다른 PDT 버전을 설치한다면, 아래 명령을 따라 정확한 

버전으로 바꾸고 그림 3. php.ini의 Zend 디버거 디렉토리 이름도 바꾼다. 

2. Eclipse 워크스페이스 디렉토리를 만든다. (예: md c:\eclipse\workspace). 

3. MySQL 라이브러리로 PDT를 설정한다: 

l MySQL PHP 커넥터 웹 사이트로 간다. 

l mysqli 확장 (PHP 5.2.0)용 링크를 클릭한다. 

l .zip 파일을 다운로드 하고(예: php_5.2.0_mysqli_5.0.27-win32.zip) c:\temp\dw-ajax 

디렉토리에 저장한다. 

4. c:\eclipse\plugins\org.zend.php.debug.debugger.win32.x86_0.1.7\resources\php

5 디렉토리 (Unzip.exe php_5.2.0_mysqli_5.0.27-win32.zip -d 

C:\eclipse\plugins\org.zend.php.debug.debugger.win32.x86_0.1.7\resources\php

5)에 .zip 파일의 압축을 푼다. 

5. C:\eclipse\plugins\org.zend.php.debug.debugger.win32.x86_0.1.7\resources\php

5\php.ini 파일을 편집하고 이 파일의 내용을 그림 3. php.ini의 내용으로 대체한다. 다음

과 같이 변경하고 파일을 저장한다: 

l php.ini 파일의 내용을 대체한 후에,[Zend] 섹션 아래의 처음 두 개의 라인들을 합병한다

extension_dir=C:\eclipse\plugins\org.zend.php.debug.debugger.win32.x86_0.1.7\

resources\php5 

l 필요할 경우, 이것을 정확한 Zend 디버거 디렉토리 이름으로 수정한다. 

6. c:\eclipse 디렉토리로 전환하고 eclipse.exe를 입력하여 Eclipse를 시작한다. 

7. Workspace Launcher 다이얼로그 박스에서, 워크스페이스를 c:\eclipse\workspace로 

바꾸고 OK를 클릭한다. 

8. Eclipse IDE의 Welcome 탭을 닫는다. 

9. Eclipse IDE에서 Window->Open Perspective->Other를 선택하고, PHP를 선택하고 

OK를 클릭한다. 

10. IDE의 왼쪽 하단 프레임에서, PHP Functions 뷰를 선택한다. 빌트인 PHP 라이브러리 

함수 리스트가 보이는지를 확인한다. 

11. Eclipse에서, Window->Preferences를 클릭한다. 

l 확장하여 PHP->Debug를 선택한다. 

l Break at First Line 체크 박스를 선택하고 Apply를 클릭한다. 

l 같은 PHP Debug 페이지에서, Debug Options 섹션에 나타나는 PHP Servers ...를 선택

한다. 

l 리스트에서, Default PHP Web Server를 선택하고 Edit을 클릭한다. 

l Publish Projects to this Server 체크 박스를 선택한다. 

l Directory 필드에서, c:\Program Files\Zend\Apache2\htdocs를 검색하고 OK를 클

릭한다. (그림 4. Eclipse PDT 설정) 

l OK를 클릭한다. 

l OK를 클릭하고 Preferences 다이얼로그를 닫는다. 
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; Remember to merge the first two lines below the [Zend] section

; to appear in one line.

; Otherwise, Eclipse PDT (PHP Development Tool) will not work properly.

; If needed, modify it with the correct Zend debugger directory name

; as in your Eclipse installation.

[Zend]

extension_dir=

  

C:\eclipse\plugins\org.zend.php.debug.debugger.win32.x86_0.1.7\resources\ph

p5

include_path="."

extension=php_mysqli.dll

zend_extension_ts=.\ZendDebugger.dll

zend_debugger.allow_tunnel=127.0.0.1/32

zend_debugger.allow_hosts=127.0.0.1/32

zend_debugger.expose_remotely=always

그림 3. php.ini 

그림 4. Eclipse PDT 설정

12. Window->Web Browser->Firefox를 선택한다.
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마. Aptana 웹 IDE 설치

다음 단계를 따라, 최신 버전의 Ajax 개발용 Aptana Web IDE를 설치한다. 

1. Eclipse의 Help 메뉴에서 Software Updates->Find and Install...를 선택하여 

Install/Update 팝업 창을 연다. 

l Install/Update 팝업 창에서, Search for new features to install 옵션을 선택하고 Next

를 클릭한다. 

l 업데이트를 검사할 새로운 원격 사이트를 설정하려면, New Remote Site... 버튼을 클릭

하여 New Update Site 팝업 창을 연다. 

l New Update Site 팝업 창에서, Site Name 텍스트 박스에서 Aptana를 입력한다. 

l URL 텍스트 박스에서, Aptana 업데이트 사이트 URL: 

http://update.aptana.com/install/3.2/로 가고 OK를 클릭한다. 

l Finish를 클릭하여 Updates 창을 연다. 

l Update 창에서, Aptana update 체크 박스를 선택하고 Next를 클릭한다. 

l 옵션을 선택하여 라이센스 동의 조건을 수락하고 Next를 클릭한다. 

l Finish를 클릭한다. 

l Feature Verification 다이얼로그 박스가 뜨면 Install All을 선택한다. 

l Eclipse를 재시작 하라는 프롬프트에서, Yes를 클릭하여 재시작 한다. 

2. Eclipse IDE에서, Window->Open Perspective->Other를 선택하고 OK를 클릭한다. 

Aptana 퍼스펙티브가 활성화 되면 설치는 성공한 것이다. 

지금까지 모든 것이 실행된다면, XHTML, JavaScript, XHR, PHP, MySQL 코드 같은 은행 

시나리오 애플리케이션 생성물들을 개발, 테스트, 디버깅 할 때 사용할 수 있는 Eclipse IDE

가 생긴 것이다. Eclipse IDE는 Zend Core PHP 서버에서 작동하도록 설정된다. Eclipse와 

Zend Core의 동적인 결합은 모든 Ajax 개발에 필요한 설치를 완료하였다. 

5. Ajax-PHP 기반 개발방법

그림 5. 은행업무 시나리오는 Ajax-PHP 환경에서 뱅킹 관련 함수들을 제공하는 시나리오를 

묘사하고 있다. 이 시나리오에서는 일부 기술 컴포넌트를 소개하고 다음과 같은 3개의 티어

로 확장함으로써 전통적인 아키텍처 스타일을 따른다. 

l 클라이언트 티어 

l 미들 티어 

l 데이터 티어 

클라이언트 티어에서, 이 시나리오는 싱글 페이지 XHTML 사용자 인터페이스 엘리먼트와 

XHR과 JSON을 통해 실행되는 브라우저 기반 컨트롤을 사용한다. 미들 티어에서, 

SimpleXML, Services_JSON, HTTP 요청 프로세서, PHP SOAP 클라이언트 같은 PHP 기

술을 사용한다. 데이터 티어에서, SQL과 ODBC를 사용한다. 

본 시나리오는 적용된 기술 컴포넌트에 따라 나뉠 수도 있다. 

l 브라우저 

l PHP 서버 
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그림 5. 은행업무 시나리오

l PHP 웹 서비스 클라이언트 

l 데이터베이스 서버 

l 인터넷에 호스팅 된 .NET 기반 서드 파티 웹 서비스 

본 시나리오는 기본적이고 중요한 Ajax 측면을 만족시키고 있다. 많은 기술 솔루션들 중에

서, 여러분의 잠재성을 확대화 하는 특정 구현 방식을 선택하게 될 것이다. 전체적인 디자인 

목표는 클라이언트 티어에 불필요한 플래시 스크린들을 제공하여 시나리오를 복잡하게 하지 

않는 것이다. Eclipse IDE (PDT와 Aptana)와 Zend Core의 콘텍스트 내에 다양한 시나리오 

생성물들의 개발과 전개에 개입된 상세를 더욱 쉽게 이해하기 쉽도록 조치를 취했다. 게다

가, 본 시나리오는 인터넷에 호스팅 된 .NET 기반의 실제 웹 서비스에 대한 PHP 웹 서비스 

클라이언트를 포함시킴으로써 상호 운용성을 드러낸다. 앞서 언급했듯이, 선택된 오픈 소스 

오퍼링의 핵심 구현 블록에 초점을 맞추기 위해서, 본 시나리오에서는 보안, 확장성, 가용성 

부분은 다루지 않는다. 

가. 은행 데이터(MySQL) - 데이터

은행의 고객 관련 정보는 데이터베이스 테이블에 저장된다. 이 테이블을 MySQL 데이터베이

스에 만들 것이다. 크기는 작지만 강력한 커뮤니티 에디션 서버이다. 모든 고객 데이터는 데

이터베이스 테이블에 한번에 배치될 것이다. 이후에, 저장된 고객 데이터는 Zend Core에서 

제공하는 ODBC 드라이버를 통해 검색 및 업데이트 될 수 있다. 읽기 또는 쓰기 같은 데이
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터베이스 액세스 유형은 은행 출납 기능의 특성에 기반하여 결정된다. 

나. 은행 로직함수(PHP) - 모델

은행 출납 기능을 제공하는데 필요한 핵심 은행 로직에 대해 생각해 보자. 이 시나리오에서 

다음과 같은 함수들을 지원해야 한다. 

l 은행의 모든 고객에 대한 계좌 정보를 가져온다. 

l 특정 계좌에 돈을 예금한다. 

l 특정 계좌에서 돈을 빌린다. 

l 특정 계좌용 통합 포트폴리오 리포트를 가져온다. 

이러한 네 개의 함수들은 데이터베이스로 액세스해야 하므로, 필수 데이터베이스 함수를 제

공하기 위한 PHP 파일이 생성된다. 미들 티어 로직의 나머지로부터 데이터베이스 함수들의 

캡슐화가 가능하다. 이러한 방식으로 핵심 은행 출납 함수들을 노출함으로써, 이러한 함수들

의 모든 콜러에 대해 공통 방식으로 데이터베이스 결과를 압축할 수 있다. PHP 제휴 어레이

(associative array)는 핵심 은행 로직의 결과를 제공한다. 

다. 은행 포털사용자 인터페이스(Ajax) - 뷰

은행 출납용 사용자 인터페이스를 제공하여 네 개의 핵심 함수를 실행한다. PHP 코드로 캡

슐화 된 핵심 은행 로직은 Thick 또는 Thin 클라이언트를 통해 액세스 될 수 있다. 이 시나

리오는 은행 출납원을 위한 단일 페이지 기반 Ajax 브라우저 사용자 인터페이스를 개발하는 

부분을 다룬다. 

PHP가 미들 티어에 사용될 때, PHP 코드가 필수 XHTML, CSS, JavaScript 결과를 만들어 

내는 것이 일반적이다. 이 시나리오에서, 우리는 PHP 코드가 어떤 클라이언트 사용자 인터

페이스 코드도 만들지 않도록 할 것이다. 다시 말해서, Bank Portal과 관련된 모든 코드는 

클라이언트 시작 동안에만 제공될 것이다. 개발자는 XHTML과 CSS로 모든 사용자 인터페이

스 엘리먼트를, JavaScript로 클라이언트 측 로직을 코딩 할 것이다. 이러한 모든 생성물들

(XHTML, CSS, JavaScript)에는 은행 시나리오의 Bank Portal 요구 사항을 만족시키는데 

필요한 모든 사용자 인터페이스 엘리먼트가 포함된다. Apache 웹 서버는 클라이언트 사용자 

인터페이스 관련 콘텐트를 브라우저에 단 한번 제공해야 한다. 브라우저로의 단 한번의 코드 

전달은 은행 출납원이 이 애플리케이션용 URL을 방문할 때 수행된다. 이렇게 되면, Bank 

Portal 클라이언트는 XHTML, CSS, JavaScript 같은 프리젠테이션 콘텐트용이 아닌 데이터 

교환 전용 서버로 연결된다. 

이것은 클릭하고 기다리는(Click and Wait) 패러다임 관행의 시작이다. 여기에서, 브라우저

는 미들 티어 서버로 연결하여 모든 사용자 액션에 프리젠테이션 콘텐트를 다운로드 한다. 

단일 페이지 기반 Ajax 애플리케이션의 특출한 기능 중 하나는 프리젠테이션 콘텐트의 초기 

다운로드에서 나오는 더 이상의 페이지를 수행하지 않는다는 것이다. 이 포인트 뒤에, 단일 

페이지 기반 Ajax 클라이언트 애플리케이션은 애플리케이션 스팩의 데이터 교환만을 위해서 

미들 티어 서버 로직과 연결한다. 따라서 프리젠테이션 콘텐트를 브라우저에 제공하는 추가 
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부담 없이 순수하게 비즈니스 로직에만 집중하는 미들 티어 로직이 생긴다. 이러한 방식은 

애플리케이션 티어들을 분리하여 깨끗하고 고급스러운 웹 애플리케이션 디자인이라는 결과를 

만들어 낸다. 

라. 은행 액션 모듈(PHP) - 콘트롤러

은행 출납원에 의해 선택된 은행 액션이 네트워크를 통해서 수행되는 방법을 생각해 보자. 

이 시나리오에서, 텔러가 선택한 Bank Actions 명령어와 필요한 인풋 데이터를 PHP 코드 

모듈로 보내는데, 이는 브라우저와 PHP 모듈에 있는 핵심 은행 로직 간 중개자로서 작동한

다. Bank Actions PHP 모듈은 미들 티어에서 REST 스타일의 서비스 함수 호출을 지원하

도록 설계된다. Bank Actions PHP 모듈은 Bank teller Action 명령어를 받고 Bank Logic 

PHP 모듈로의 함수 호출을 실행하여 필요한 결과를 얻는다. Bank Logic 모듈이 리턴되면, 

Bank Actions 모듈은 JSON 포맷의 데이터로 결과를 브라우저로 보낸다. Bank Actions 

PHP 모듈은 적절한 Bank Logic 함수를 호출하여 요청을 처리하는 은행 출납 요청을 위한 

디스패처(dispatcher)로서 작동한다. 

마. XML 웹 서비스 클라이언트 - 헬퍼

브로커/중개자가 되는 것 외에도, Bank Actions PHP 모듈은 PHP Web Service SOAP 클

라이언트로서 작동하여 해당 고객 포트폴리오에 저장된 현재 주식 시세를 가져온다. 이는 

PHP로 웹 서비스 클라이언트를 생성하는 것을 배울 수 있는 좋은 기회이다. 이 시나리오에

서, Bank Actions PHP 모듈은 인터넷에서 실행되는 원격의 실제 웹 서비스로 SOAP XML 

웹 서비스 호출을 한다. 또한, PHP SimpleXML API를 사용하는 XML 파싱에 대해서도 배

울 수 있다.
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