Home > 정보마당 > 공개SW 보안취약점

공개SW 보안취약점

jQuery 1.8.2

License 관리자 2021-01-22 09:17:41 61
컴포넌트 명 : jQuery
컴포넌트에 대한 취약점 정보
버전 정보 취약점 ID 취약점 최종 보고일 심각도
1.8.2 CVE-2020-11023 2020/12/08 4.3 (Medium)
취약점 ID : CVE-2020-11023
취약점 상세정보
취약점 설명

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.



1.0.3 이상 및 3.5.0 이전의 jQuery 버전에서, 신뢰할 수 없는 소스의 요소를 포함하는 HTML을 jQuery의 DOM 조작 메서드 중 하나(예, .html(), .append() 등)로 전달하는 것은 신뢰할 수 없는 코드를 실행할 수 있습니다. 이 문제는 jQuery 3.5.0에서 패치되었습니다.

대응 방안 3.5.0 이상 버전으로 업데이트
기타 -

-

공개SW 보안취약점 게시물 리스트 표
번호 컴포넌트 명 및 버전 취약점ID 심각도 취약점
최종 보고일
대응방안
141 parsejson 0.0.2 CVE-2017-16113 5.0 (Medium) 2019/10/09
140 SockJS 0.2.1 CVE-2020-8823 4.3 (Medium) 2021/01/12
139 jQuery 1.8.2 CVE-2020-11023 4.3 (Medium) 2020/12/08
138 jQuery 1.4.2 CVE-2007-2379 5.0 (Medium) 2019/04/16
137 Strapi 3.0.0-alpha.4 CVE-2019-19609 9.0 (Critical) 2019/12/18
136 Django 2.2.3 CVE-2019-14234 7.5 (High) 2019/08/28
135 Django 2.2.3 CVE-2020-7471 7.5 (High) 2020/06/18
134 Nanopb 0.3.9 CVE-2020-5235 7.5 (High) 2020/02/06
133 pip 19.0.3 CVE-2019-20916 5.0 (Medium) 2020/10/04
132 ruamel-yaml 0.16.7 CVE-2019-20478 10.0 (Critical) 2020/02/27
맨 위로
맨 위로