Home > 정보마당 > 공개SW 보안취약점

공개SW 보안취약점

컴포넌트 명 : Apache Jakarta HttpComponents
컴포넌트에 대한 취약점 정보
버전 정보 취약점 ID 취약점 최종 보고일 심각도
4.3 CVE-2014-3577 2014/08/21 5.8 (Medium)
취약점 ID : CVE-2014-3577
취약점 상세정보
취약점 설명 Apache HttpComponents의 org.apache.http.conn.ssl.AbstractVerifier 4.3.5 이전의 HttpClient 및 4.0.2 이전의 HttpAsyncClient는 서버 호스트 이름이 해당 호스트의 공통 이름 (CN) 또는 subjectAltName 필드의 도메인 이름과 일치하는지 제대로 확인하지 않습니다. X.509 인증서는 man-in-the-middle 공격자가 인증서의 고유 이름 (DN) 필드의 "CN ="문자열을 통해 SSL 서버를 스푸핑 할 수 있도록 합니다.
대응 방안 4.3.5 이상 버전으로 업데이트.

2018.10.26

공개SW 보안취약점 게시물 리스트 표
번호 컴포넌트 명 및 버전 취약점ID 심각도 취약점
최종 보고일
대응방안
13 Ubuntu 18.04.1 LTS CVE-2018-7184 7.5 (High) 2018/03/06
12 Rasbian 4.14 CVE-2014-9295 7.5 (High) 2014/12/19
11 CentOS 7(1708) CVE-2018-1000199 5.5 (Medium) 2018/05/24
10 Apache PDFBox 2.0.8 CVE-2018-8036 5.5 (Medium) 2018/07/03
9 Apache POI 3.12 CVE-2017-12626 7.5 (High) 2018/01/29
8 Apache Commons FileUpload 1.3.1 CVE-2016-1000031 9.8 (Critical) 2016/10/25
7 Apache Commons Collections 3.2.1 CVE-2017-15708 9.8 (Critical) 2018/01/08
6 libssh 0.6 이상 CVE-2018-10933 9.1 (Critical) 2018/10/23
5 Apache Jakarta HttpComponents 4.3 CVE-2014-3577 5.8 (Medium) 2014/08/21
4 Apache-Jakarta HTTP Client 3.1 CVE-2012-5783 5.8 (Medium) 2012/11/04
맨 위로
맨 위로