Home > 정보마당 > 공개SW 보안취약점

공개SW 보안취약점

컴포넌트 명 : Bouncy Castle
컴포넌트에 대한 취약점 정보
버전 정보 취약점 ID 취약점 최종 보고일 심각도
1.45 CVE-2018-5382 2020/08/31 7.5 (High)
취약점 ID : CVE-2018-5382
취약점 상세정보
취약점 설명 Bouncy Castle BKS version 1 keystore (BKS-V1) files use an HMAC that is only 16 bits long, which can allow an attacker to compromise the integrity of a BKS-V1 keystore. All BKS-V1 keystores are vulnerable. Bouncy Castle release 1.47 introduces BKS version 2, which uses a 160-bit MAC.

Bouncy Castle BKS 버전 1 키스토어 (BKS-V1) 파일은 길이가 16 비트에 불과한 HMAC를 사용하므로 공격자가 BKS-V1 키스토어의 무결성을 손상시킬 수 있습니다. 모든 BKS-V1 키스토어는 취약합니다. Bouncy Castle 릴리스 1.47에는 160 비트 MAC을 사용하는 BKS 버전 2가 도입되었습니다.
대응 방안 -
기타 -

-

공개SW 보안취약점 게시물 리스트 표
번호 컴포넌트 명 및 버전 취약점ID 심각도 취약점
최종 보고일
대응방안
117 Apache Hadoop 0.16.0 CVE-2017-3162 7.5 (High) 2020/06/04
116 Apache Hadoop 0.16.0 CVE-2012-4449 7.5 (High) 2017/11/21
115 Bouncy Castle 1.45 CVE-2018-1000613 7.5 (High) 2019/04/24
114 Bouncy Castle 1.45 CVE-2018-5382 7.5 (High) 2020/08/31
113 Apache Tomcat 8.0.30-windows-i64 CVE-2020-8022 7.2 (High) 2020/09/02
112 Apache Tomcat 8.0.30-windows-i64 CVE-2018-8014 7.5 (High) 2019/10/02
111 Apache Tomcat 8.0.30-windows-i64 CVE-2016-8735 7.5 (High) 2019/04/23
110 Apache Tomcat 8.0.30-windows-i64 CVE-2016-8735 7.2 (High) 2020/07/23
109 Apache Tomcat 8.0.30-windows-i64 CVE-2016-3092 7.8 (High) 2019/04/23
108 Apache Xerces2 J 2.10.0 CVE-2012-0881 7.8 (High) 2019/10/18
맨 위로
맨 위로